How to fix the Evo 4g Purple Camera issue

I have been using the HTC EVO 4g for quite some time now, almost 2 years. I have never really had any issues with it, and it has always been a reliable phone. Unfortunately, due to my hacking adventures with it, a few months ago, my phone shut down, and would not turn on, it would simply show the HTC logo screen, turn off, and do it again. It wouldnt let me put it into recovery, or respond to any of my commands. I bit the bullet and took it in to Sprint, and they gave me a replacement. Unfortunately, the replacement after a month or two began to show a strange purple tinge, and it got worse and worse. I flashed different roms to the phone, thinking it may be a software issue, but it did not help. I finally took it into the store, and they confirmed that it was a hardware issue and fixed it in just a few minutes. A few days ago I had the same issue, and I did not want to go to the store, since the wait is ridiculous, so I started looking online for the answer, and lo and behold, I found it! Read on to see what fixed it!

First of all, take a look at the pictures below, and see if the issue you are having is similar to what I had. Below are 2 images, the first when I had the issue, and the second after I fixed it.

To fix it, simply use your finger and press down on the camera. It may leave your lens a bit smudged so make sure to wipe it after you are done. I made sure to be in the camera app of the evo, then I pressed down gently but firmly, until the screen showed a normal image. You can tell it worked, because all the purple is gone, and you only have black. I hope this helps, and if you have any questions, be sure to sound off in the comments.

2018-07-10T18:15:02+00:00